Поддержка Проблемы и решения Проблемы после обновления 5.5

  • После вашего крутого обновления:
    1. Перестал работать плагин: Yoast SEO и Rank Math SEO
    2. в новых записях вкладка «редактировать в elementor» тоже пропала
    3. при создании записи и ее редактировании при выборе любого блока сразу ошибка.
    4. Тема стоит последняя soledad Версия: 7.3.2
    5. Все плагины обновил.
    Ну и что дальше делать? Работал себе сайт нормально теперь геморой подкинули

Просмотр 15 ответов — с 31 по 45 (всего 48)
  • После обновления перестала загружаться одна галерея, ей требовались картинки до построения. Пришлось допилить виджет загружающий картинки, чтобы внести в него опцию для lazy load.

    Документатия здесь https://make.wordpress.org/core/2020/07/14/lazy-loading-images-in-5-5/

    Мне достаточно было добавить в функцию wp_get_attachment_image параметр eager

    wp_get_attachment_image(
        42,
        'large',
        false,
        array( 'loading' => eager),
    );

    Ну а всё-таки кто нибудь подскажет, как отключить автоматическое обновление ВордПресс? У меня все объявления сначала «рекомендовали» обновится, я всегда игнорировал, потом через какое-то время обновление происходит автоматически. Тоже и с версией 5.4, и теперь я понимаю, откуда ноги растут. Сейчас настойчиво рекомендует обновиться до 5.5. Вопрос: а это что вообще получается — все разработчики тем и плагинов обязаны под каждую новую версию ВордПресса делать обновы? А им кто-то изначально вменил такую обязанность или это теперь по ходу они вдруг стали кому-то что-то должны? А если честно говоря, без тех тем и плагинов сам по себе ВордПресс никому вообще не нужен, какой бы он версии ни был. Я конечно понимаю, что виноват кто угодно, например, Яндекс виноват, после обновления до 5.4 он выкинул с индекса почти половину страниц, разработчики конечно здесь не причем. Но мне дешевле будет вообще не связываться с этими «разработками», которые как любая система куда-то там эволюционируют. Я прошу лишь одного — кто знает, как отключить обновление? И как откат до старой версии с помощью плагина (о нем писали выше) скажется на работоспособности сайта? Или не рисковать, а все удалить и ставить нужную старую версию заново?

    Пост запрос на /wp-admin/admin-ajax.php вернул 503 (Service Temporarily Unavailable)

    Раньше все работало хорошо.

    • Ответ изменён 3 года, 9 месяцев назад пользователем Mike Shilov.

    После обновления часть функциональности темы отвалилась. Здорово, конечно, советовать пинать разрабов плагинов и пользоваться поддерживаемыми темами. У меня несколько сайтов, разработанных ранее другими людьми. Темы уже не поддерживаются.
    Надо было в релизнотах так и написать: ваши сайты — это ваши проблемы, у нас все збс. Обратная совместимость для слабаков.

    Модератор Yui

    (@fierevere)

    永子

    адо было в релизнотах так и написать: ваши сайты — это ваши проблемы

    зачем? Это уже написано в лицензии.
    п 11 и 12
    не читали? или не считаете нужным читать лицензии и соглашения для того, чем пользуетесь ?

    зачем? Это уже написано в лицензии.
    п 11 и 12
    не читали? или не считаете нужным читать лицензии и соглашения для того, чем пользуетесь ?

    Вы же вроде для других людей это делаете? WP завоевал популярность своей доступностью и множеством решений повседневных задач веб-разработчиков. С обновлением уйма разработчиков теперь получила множество повседневных проблем.

    С таким же подходом, полагаю, Ангуляр выкатывал свою вторую версию. Сейчас уже 9 версия, а отголоски и опасения до сих пор витают в обсуждениях.

    кто знает, как отключить обновление?

    Откатитесь на хостинге (смотря когда вы апались до 5.5). При условии, что не много изменений, конечно, было сделано.

    Модератор Yui

    (@fierevere)

    永子

    norzserge

    jQuery давно прекратили поддержку этой версии.
    С вашим подходом к «обратной совместимости», разработчики WP должны взять на себя вечную поддержку старой версии?

    Может и древние версии PHP продолжать поддерживать? Там же тоже дырки лезут во всю… В апстриме самая старая ветка — 7.1
    а WP что-то с 5.6 все еще возится… Надо форкать же, да? патчить?
    Всё для людей, причем абсолютно бесплатно, и даже не за спасибо, а только чтобы претензии не кидали.

    А если серьезно, то WP поддерживается (пока что) начиная с ветки 3.7, хоть и речь о прекращении поддержки настолько старых версий периодически поднимается, но они всё еще поддерживаются.
    Скажите, вас заставили ставить 5.5 ?

    Скажите, вас заставили ставить 5.5 ?

    До 5.5 все обновления не несли за собой повальные проблемы у большого количества девелоперов, потому апнулся без задней мысли. А так, конечно, меня никто не заставляет это делать.

    Всё для людей, причем абсолютно бесплатно, и даже не за спасибо, а только чтобы претензии не кидали.

    Скажите, вас кто-то заставляет этим заниматься? Сомневаюсь. Видимо, есть свой интерес, так что не прибедняйтесь. Да и подача ваша выглядит странно: жрите, товарищи и помалкивайте — ведь бесплатно, а если не нравится — читайте, что написано на входе: «Ваша ожидания — это ваши проблемы» (п. 11 и 12). В таком ключе вы мне сейчас презентуете ваш релиз и только больше негатива в свой адрес вызываете.

    Касательно советов пользоваться поддерживаемыми темами и пинать разработчиков плагинов. Вы же прекрасно понимаете какой процент юзеров сидит на старых темах и плагинах… Странно получать от вас, как от представителя, подобные советы. Популярность WP держится на этом. Сегодня разработчик плагина поправил баги, а завтра забил на них, а тут 5.5 выкатывают. Что делать посоветуете? Искать альтернативы?

    Может и древние версии PHP продолжать поддерживать? Надо форкать же, да? патчить?

    Нет, взять и повалить тысячи сайтов одним релизом. Если для вас это ок, что ж…этот релиз многие запомнят.

    Вы же прекрасно понимаете какой процент юзеров сидит на старых темах и плагинах…

    подозреваю что не большой, а большинство пользователей — разумные люди

    Модератор Yuri

    (@yube)

    Вот можно подумать, что всё остальное в этом мире — и мягкое, и твердое — после обновлений продолжает поддерживать устаревшие запчасти, и только один WordPress выделился на этом благостном фоне.

    как от представителя

    От представителя сообщества пользователей. Такого же, как и Вы, только вносящего свой посильный вклад в общее дело. Если Вы еще не поняли, это форум волонтеров. Так что Ваши претензии к своим же коллегам (и друзьям по несчастью, кстати) совершенно неуместны, чтобы не сказать оскорбительны.

    Модератор Yui

    (@fierevere)

    永子

    В таком ключе вы мне сейчас презентуете ваш релиз и только больше негатива в свой адрес вызываете.

    я вам ничего не презентую.
    Я бы сказала, что нам вообще не нужны такие пользователи,
    которые даже не говорят спасибо, предьявляют претензии,
    не следят за новостями выпуска и даже не читали лицензию

    Хорошего дня. Можете написать свою CMS, если не нравится.
    Ведете себя так, как будто вам прямо обязаны.

    Скажите, вас кто-то заставляет этим заниматься? Сомневаюсь. Видимо, есть свой интерес, так что не прибедняйтесь. Да и подача ваша выглядит странно: жрите, товарищи и помалкивайте — ведь бесплатно, а если не нравится — читайте, что написано на входе: «Ваша ожидания — это ваши проблемы» (п. 11 и 12). В таком ключе вы мне сейчас презентуете ваш релиз и только больше негатива в свой адрес вызываете.

    Хакеры очень любят сайты на движке WordPress из-за своей распространенности. Можно конечно не обновлять и оставить все как есть, но потом не нужно удивляться, если в 1 прекрасный день Ваш сайт хакнут.

    • Ответ изменён 3 года, 9 месяцев назад пользователем alexander70.
    Модератор Yui

    (@fierevere)

    永子

    Хакеры любят любую массовку. В ней можно найти тех, кого легко взломать. Редкие CMS и самописные сайты будут ломать разве что на заказ (что как часто тоже оказывается достаточно несложной задачей, гораздо более простой чем сломать WP, где надо найти еще уязвимое место)

    Давайте расставим точки.
    Я уважаю труд и разработчиков системы, и волонтеров, и всех участников open source ресурса. Система должна развиваться и идти в ногу со временем. Те, кто этим занимаются — молодцы. Спасибо.

    Но первое, что меня зацепило — это отношение со стороны волонтеров (а именно товарища Yui), которая высказалась в ответ на замечание — «это ваши проблемы», «нам такие пользователи системы не нужны» (не дословно). А что вам нужно? Только чтобы вам пели дифирамбы? А те, кому не нравятся — могут свою CMS написать? Здорово. Соберитесь узким кружочком и говорите друг другу «спасибо» и не дай-то Бог кто-то вам выскажет претензию относительно вашей работы — исключите из кружка.

    Не всем по вкусу пришлось обновление, потому что сайты полегли. Мне кажется, что это закономерно, правда? Существуют полифилы, существуют нотификации в самой системе. Миграцию можно было бы осуществить более мягко, а не просто «Доступна версия 5.5, пожалуйста обновитесь», после чего отваливается половина сайта. Или вы реально думаете, что разработчики, сайты которых в одно мгновение обросли багами, будут сиять от счастья?

Просмотр 15 ответов — с 31 по 45 (всего 48)
  • Тема «Проблемы после обновления 5.5» закрыта для новых ответов.