Поддержка Проблемы и решения Сайт на Вордпресс функционирует с ошибками

  • Обновил сайт на Вордпресс на последнюю версию Вордпресс. Плагины не работают, не могу зайти в панель администратора. Сипэнел доступна, ЭфТиПи тоже работает. При попытке зайти в панель администратора пишет, что такой страницы не существует.

    Как восстановить доступ к панели администратора? Если откатить к последней сохраненной копии сайта, может исчезнуть последняя публикация. Это предлагают хостеры. Не имею доступа к серверу.

Просмотр 12 ответов — с 31 по 42 (всего 42)
  • Модератор Юрий

    (@yube)

    А ведь минимально требуется 7.4.

    Где? Кому?

    По второй ошибке они говорят, что не знаимались разработкой моего сайта. Поэтому не могут помочь.

    Ещё малоприятный момент. Начиная с версии Вордпресса 5.3, пропадают некоторые фотографии, особенно по размеру больше 1 мбайта. Приходится или перезаливать их, или закачивать их на сторонние фотосервисы и делать на них ссылку в своих статьях.

    Юрий, в одной официальной англоязычной статье на Вордпрессе читал такое требование.

    Модератор Yui

    (@fierevere)

    ゆい

    у вас есть доступ к командной строке сервера?
    в панели хостиинга или через ssh?

    можете выполнить там команду

    curl -I https://blog.daniyar.info

    что на выдаче?

    Или пусть ТП хостинга попробует. Важно сделать это именно с сервера на котором находится ваш сайт. Внешне всё нормально.

    Модератор Yui

    (@fierevere)

    ゆい

    в одной официальной англоязычной статье на Вордпрессе читал такое требование.

    И вероятно перепутали «требование» и «рекомендацию»
    WP всегда рекомендует использовать последнюю стабильную версию PHP.
    Минимальное требование (на котором будет работать) — 5.6.20
    Минимальная версия на которой в консоли не будет выдаваться надоедливый виджет про необходимость обновить PHP — 7.2 (виджет кстати в настройках экрана отключается)

    МодераторYui (@fierevere)
    ゆい

    12 минут назад
    в одной официальной англоязычной статье на Вордпрессе читал такое требование.

    И вероятно перепутали «требование» и «рекомендацию»

    Говорилось, что минимум 7.4 должно быть. Факт, что даже 7.3 на моем сайте нельзя установить.

    • Ответ изменён 1 неделя, 4 дня назад пользователем kvkkvk.

    у вас есть доступ к командной строке сервера?
    в панели хостиинга или через ssh?

    можете выполнить там команду

    curl -I https://blog.daniyar.info

    что на выдаче?

    
    'abrt-cli status' timed out
    [daniyar@host ~]$ curl -I https://blog.daniyar.info
    HTTP/1.1 200 OK
    Date: Sun, 28 Jun 2020 14:50:24 GMT
    Server: Apache
    X-Powered-By: PHP/7.2.31
    Link: <https://blog.daniyar.info/wp-json/>; rel="https://api.w.org/", <https://wp.me/4HMEm>; rel=shortlink
    Upgrade: h2,h2c
    Connection: Upgrade
    Cache-Control: max-age=600
    Expires: Sun, 28 Jun 2020 15:00:24 GMT
    Vary: Accept-Encoding,User-Agent
    Accept-Ranges: none
    Content-Type: text/html; charset=UTF-8
    
    [daniyar@host ~]$
    
    Модератор Yui

    (@fierevere)

    ゆい

    тогда это не может быть официальной статьей.

    Офиц требования — https://wordpress.org/about/requirements/
    https://ru.wordpress.org/about/requirements/
    Обратите внимание на слово «рекомендуется»

    https://wordpress.org/news/2019/04/minimum-php-version-update/
    повышение минимальной версии до 5.6.20

    https://wptavern.com/wordpress-bumps-minimum-php-recommendation-to-7-2
    https://meta.trac.wordpress.org/ticket/5257
    https://meta.trac.wordpress.org/changeset/9959
    русский вариант трех последних ссылок — https://oddstyle.ru/wordpress-2/novosti-wordpress/wordpress-podnimaet-minimalno-rekomenduemuyu-versiyu-php-do-7-2.html

    Модератор Yui

    (@fierevere)

    ゆい

    вполне нормальный «выхлоп» curl, проблем быть не должно
    возможно у вас не очень хороший DNS сервер, выдающий при первом запросе таймауты, обновить статус «Здоровья сайта» возможно поможет убрать ошибку с curl?

    Давайте не будем разводить филологическую дискуссию. Лучше подскажите, что делать с неисправностями в заливке фотографий и с The loopback request to your site failed

    И что делать с этим: Could not confirm that the wp_version_check() filter is available.

    kvkkvk,

    Давайте не будем разводить филологическую дискуссию.

    Дискуссии и нет, есть только ошибки вашего сайта и какая-то странная информация о минимальной версии PHP 7.4. Так-то вам тут помочь пытаются, а не наоборот.

    И что делать с этим: Could not confirm that the wp_version_check() filter is available.

    Вариантов много: это вполне может быть из-за ошибки Error: cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received (http_request_failed), либо работа какого-то плагина безопасности, либо в теме где-то используется session_start(), либо глюк плагина JetPack (если такой установлен).

Просмотр 12 ответов — с 31 по 42 (всего 42)