Поддержка Проблемы и решения Сайт не правильно отображается в Сафари

  • Решено sampomiru

    (@sampomiru)


    Добрый день всем!

    У меня ситуация наверное похожа на некоторые уже описанные здесь, но чёткого решения данной проблемы я пока так и не нашёл. Поэтому попробую описать свою проблему в этой теме:
    У меня есть сайт . Во всех браузерах он отображается и функционирует нормально.
    Но в Сафари — полная беда!
    1. В некоторых местах не показываются картинки (в основном миниатюры постов, но не только).
    2. Шапка сдвинулась вправо и исчез логотип.
    3. Значки репоста также превратились в разноцветные квадратики
    4. Другие элементы плагинов также исказились и перестали работать.

    Удаление кеша, куки не помогло. На всех других браузерах работает всё нормально.

    В сафари захожу из под винды. Стоит версия Сафари 5.1.7, обновить до более поздней версии уже нельзя. Для винды Apple прекратил делать обновления (Apple больше не предлагает обновления Safari для Windows. Safari 5.1.7 для Windows была последней версией, созданной для Windows, и сейчас она устарела.).
    У друга MacOS и соответственно стоит последняя версия Safari, но проблемы те же.

    Помогите! Что не так? Может есть какой нибудь плагин? Я сам не программист, но если хорошо объяснить попробую понять).

    • Тема изменена 4 недели назад пользователем Yui. Причина: redundant link(s) deleted

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 8 ответов — с 1 по 8 (всего 8)
  • Модератор Yui

    (@fierevere)

    ゆい

    Что не так? Может есть какой нибудь плагин?

    у вас уже есть плагин, называется он WP Fastest Cache, и в нем у вас включена оптимизация CSS и JS, благодаря чему их код превращается в кашу, кушать которую Сафари напрочь может отказываться.
    Начните с того, чтобы отключить оптимизацию JS и CSS в этом плагине,
    после чего очистите кеш.

    Проверьте, насколько Сафари воспримет ваш сайт без агрессивных оптимизаций.

    Я уже думал об этом и всё что вы написали уже делал. Но ситуация не изменилась. Деактивация этого плагина также не помогает.

    • Ответ изменён 4 недели назад пользователем sampomiru.

    Деактивация этого плагина также не помогает.

    Модератор Yui

    (@fierevere)

    ゆい

    можно посмотреть как сайт себя будет вести без maxmegamenu
    возможно он конфликтует с темой

    да и тема у вас какая-то странная
    Вроде название совпадает с этой
    https://ru.wordpress.org/themes/fooding/
    (форум поддержки темы тут — https://wordpress.org/support/theme/fooding/ )
    но заголовок style.css у вас какой-то порезанный

    Да тема fooding, просто я удалил из CSS название этой темы, чтобы оно не отображалось в подвале сайта.
    maxmegamenu также не влияет. Этот плагин был установлен давно. Раньше с этим плагином сайт в Сафари работал нормально. Все эти сбои призошли недавно.

    Нашёл проблему! Оказывается всё дело в «Ускорение с помощью PageSpeed». Такая настройка у меня была включена у хостинг-провайдера в моем аккаунте. Я её выключил и всё заработало!

    Модератор Yui

    (@fierevere)

    ゆい

    т.е. просто wp fastest cache с его JS/CSS-мясорубкой было мало?
    Нужно было еще добавить мясорубку mod_pagespeed (которая делает примерно то же самое)

    неудивительно.

    простите дилетанта)) Впредь буду знать!

Просмотр 8 ответов — с 1 по 8 (всего 8)