• Приветствую, появилась такая проблема на днях, когда именно не знаю, поэтому не могу восстановить с бекапа. В общем в виджетах в правой области пропала реклама Яндекса, выдает ошибку в консоле

    Uncaught TypeError: Cannot read properties of undefined (reading 'push')

    На этот код

    <script>window.yaContextCb.push(()=>{

    Но что интересно это только на страницах записей, например https://southklad.ru/katalog-monet/yubilejnye-monety-sssr-rossii-1965-1996/1-rubl-1991-goda-125-let-so-dnya-rozhdeniya-russkogo-fizika-p-n-lebedeva.html на главной и в рубриках все он. Такое чувство что именно на страницах записей все виджеты сломались. Как узнать причины и самое главное починить? Спасибо

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 8 ответов — с 1 по 8 (всего 8)
  • Сейчас смотрю, а у меня почему то на страницах записей нет скрипта от Яндекса который подключается в header.php
    Как такое может быть, на главной и в рубриках он есть, а на страницах записей этот скрипт не подключается? Ведь в header.php он точно есть.

    Помогите решить проблему

    В header.php точно есть (на диске) или плагином подключается? Похоже что по какому-то условию выводится не везде.
    Там у вас еще и Google tag (gtag.js) по такому же принципу подключается.

    • Ответ изменён 1 год, 6 месяцев назад пользователем Igor.

    Есть конечно, ведь на главной и на категориях все норм, не показывается только на страницах записей. Я уже и плагины все отключал и что только не делал и результат такой же. Файлы перезаливал тоже.

    Причем самое интересно, что это происходит выборочно. Там вставлено несколько скриптов, но отображаются только два, а два Яндекса и Гугла как будто и нет их. Ничего не понимаю.

    Для эксперимента удалил вообще файла header.php и вот с записями вообще ничего не произошло, они как были так и есть, это стало заметно только там где реклама есть. Не понимаю как это работает!

    Так причём тут header, если в виджете поломалось?

    Я же писал ниже, что оказалось дело в том, что почему то на страницах записей не подключается header полностью.

    Так а как мы поможем в слепую? Какая тема? Код header`a в студию!
    Возможно ещё проблема с кэшом, плагином для кэша. У меня было такое — вроде вносишь изменения, а ничего не меняется.

    • Ответ изменён 1 год, 6 месяцев назад пользователем Yuri_Rev.
    • Ответ изменён 1 год, 6 месяцев назад пользователем Yuri_Rev.
Просмотр 8 ответов — с 1 по 8 (всего 8)
  • Тема «Сломались виджеты» закрыта для новых ответов.