Создание тестовой версии сайта на локальном диске
-
Обожгу всех кипятком, но таковы реалии. )))
Чайник, который собрался сделать сайт на локале. Как создать, проверить работоспособность и потом перейти к реальному хостингу.?
Версию скачал русскую.
-
А у Вас виста или 7-ка? На висте помню проблемы были из-за UAC — или отключите совсем, или попробуйте запустить UwAmpUAC.exe
Также возможен конфликт, если не полностью отключен сервер майкрософта IIS.
====
То бишь запускайте все с правами администратора — правый клик — выполнить как администраторXP у меня, и работаю с правами администратора.
UwAmpUAC.exe попробую.
Вот выдал:
C:\UwAmp\bin\database\mysql-5.5.9\bin\mysqladmin.exe: connect to server at ‘localhost’ failed
error: ‘Access denied for user ‘uwamp’@’localhost’ (using password: NO)’После перезагрузки:
C:\UwAmp\bin\database\mysql-5.5.9\bin\mysqladmin.exe: connect to server at ‘localhost’ failed
error: ‘Can’t connect to MySQL server on ‘localhost’ (10061)’
Check that mysqld is running on localhost and that the port is 3306.
You can check this by doing ‘telnet localhost 3306’
Апач остановлен(((
Подключение к узлу утеряноКогда Вы запускаете uwamp то также отображается? Обвел красным.
Я с xp вообще ни разу не работал, даже не знаю, что там есть, чего нету, но судя по ошибке он говорит, что не видит процесс mysqld на порту 3306, где он и должен быть по логике вещей…
Сможете найти файл services находится c:\Windows\System32\drivers\etc\
посмотрите, что висит на этом порту 3306
=====
Еще вариант — попробуйте набрать в строке http://127.0.0.1 вместо localhostвот счас написано Апач остановлен (Apache stopped)
MySQL работает
порт 3306 не размечен вообще, хотя я его сам подключал через брэндмауэр, сча проверил работает под протоколом ТСР.
И в MySQL конфигфайле он прописан.
Сейчас виртуальный сайт не запускается. поскольку апач неживой. случилось это после полной антивирусной проверки и исправления ошибок системы.после команды ‘telnet localhost 3306’ пишет что подключение к узлу утеряно.
Вот еще интересно: общедоступный IP арес стал No available, до этого отображались цифры как положено
Какой сервиспак установлен?
Вот не понял счас.)))) ааа !!! Версия!! Сервис пак 3
AlexCar, Вы умудрились в свои посты перед
C:\UwAmpвсунуть нечто, что сломало RSS форума 🙁Ой! для меня это темный лес(((( Это что-то типа вируса?
Что сделать, чтоб не повторилось?В общем не смог я начать работать сейчас с ВП. Теперь начинается рабочая неделя, теперь только в субботу смогу к данному занятию вернуться. Спасибо за ваши сообщения настоящие и будущие — буду читать их в электронной почте.
На предыдущем скрине я отметил стрелочкой (туда нажмите), пришлось по-быстрому хр поставить в vhd
Такую же ошибку выдал, про порт, решил так:
добавил в конфиг такую строку# The MySQL server [mysqld] bind-address = 127.0.0.1 //вот эту port = 3306 socket = /tmp/mysql.sock datadir = "{MYSQLDATAPATH}"заработал после этого
(файрвол не настраивал, анвиря нет)socket = /tmp/mysql.sockЭэээ…. а давно это винда научилась работать с юникс-сокетами?
Да я и не обращал внимание на это :)) Лет 5 уже…
UPD Я хотел сказать — знать бы еще что это такое? :)))Не помогает(((
Тема «Создание тестовой версии сайта на локальном диске» закрыта для новых ответов.