Поддержка Проблемы и решения Соответствие версий PHP и WordPress

  • Решено axdr

    (@axdr)


    Где можно увидеть соответствие: какая версия PHP требуется для данной версии WordPress?
    Какая последняя версия WordPress работает с PHP 7.1?

Просмотр 4 ответов — с 1 по 4 (всего 4)
  • Модератор Yui

    (@fierevere)

    ゆい

    все свежие версии нормально работают.
    начиная с (примерно) 4.7 и до 5.4 (последней)

    Однако PHP 7.1 уже прошла срок жизни, использовать её не рекомендуется.

    https://www.php.net/supported-versions.php

    Модератор Юрий

    (@yube)

    Где можно увидеть

    В readme.html и в /wp-includes/version.php. Так чтобы отдельной табличкой — не встречал.

    Какая последняя версия WordPress работает с PHP 7.1?

    А их много, последних? ))
    WP5.3 и 5.4 требуется 5.6, рекомендуется 7.3.
    WP4.9 — 5.2 и 7.2 соответственно.

    Спасибо, друзья! Версия 5.4 установилась и запустилась без проблем.

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    Так чтобы отдельной табличкой — не встречал.

    PHP Compatibility and WordPress Versions [make.wordpress.org]

Просмотр 4 ответов — с 1 по 4 (всего 4)