Поддержка Проблемы и решения Состояние здоровья сайта показало 3 критические ошибки

  • Состояние здоровья сайта показало 3 критические ошибки.
    1. Запрос к REST API неудачен из-за ошибки.
    Ошибка: [] cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received
    2. Петлевой запрос к вашему сайту не удался. Возможности, зависящие от его работоспособности, не могут работать так, как должны.
    Ошибка: [] cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received
    3. Мы обнаружили несколько кодов отслеживания ! Вы должны удалить не MonsterInsights. Если вам нужна помощь в их поиске, прочтите эту статью .

    по 3 пункту . я удалила код аналитик в файле header/. но изменений нет.ошибку так и показывает

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 15 ответов — с 1 по 15 (всего 44)
  • Модератор Yui

    (@fierevere)

    ゆい

    по третьему пункту, нет реальных противопоказаний к использованию разной аналитики, это Monsterinsights борется с «конкурентами»
    (Плагины могут добавлять свою диагностику к Здоровью сайта)

    по поводу REST API — я у вас вижу на сайте что он работает,
    тем не менее перепроверьте настройки плагинов безопасности, если таковые у вас есть. REST API сейчас запрещать не нужно.

    попробую. спасибо. а по п.2?

    Модератор Yui

    (@fierevere)

    ゆい

    п1 и п2 у вас связаны, это по сути одна проблема
    Если у вас есть доступ к командной строке на сервере (шелл)
    можете попробовать выполнить

    curl -I https://kulinarnay-kladovay.site/wp-json/

    правильный вывод:

    
    HTTP/2 200 
    server: nginx/1.14.1
    date: Tue, 08 Oct 2019 11:11:30 GMT
    content-type: application/json; charset=UTF-8
    vary: Accept-Encoding
    vary: Accept-Encoding,Cookie
    set-cookie: PHPSESSID=тут-что-то-случайное; path=/
    expires: Thu, 19 Nov 1981 08:52:00 GMT
    cache-control: no-store, no-cache, must-revalidate
    pragma: no-cache
    x-robots-tag: noindex
    link: <https://kulinarnay-kladovay.site/wp-json/>; rel="https://api.w.org/"
    x-content-type-options: nosniff
    access-control-expose-headers: X-WP-Total, X-WP-TotalPages
    access-control-allow-headers: Authorization, Content-Type
    allow: GET

    ну либо будет сообщение об ошибке,
    можно попробовать поддержку хостинга помучать, по поводу того,
    что сайт не может установить подключение к самому себе, с ошибкой
    cURL error 28: Operation timed out after 10001 milliseconds

    хостинг просит уточнить, о какой именно странице идет речь.

    Если речь об админ-панели сайта, прошу предоставить доступы для проведения проверки с нашей стороны.
    Я честно не пойму сама, речь о странице или сайте…

    Модератор Yui

    (@fierevere)

    ゆい

    процитируйте им мое сообщение выше, пусть попробуют curl с этого же сервера на url https://kulinarnay-kladovay.site/wp-json/

    В левом верхнем углу сайта вижу: class=»home blog custom-background gllr_frontier»>

    Наверное, некорректно вставили код?

    да,я об этом уже писала раньше..мне так не ответили. это в процессе установок плагинов … ну подскажите, что за код и как это исправить?

    В левом верхнем углу сайта вижу: class=»home blog custom-background gllr_frontier»>

    Наверное, некорректно вставили код?

    нет, я исправила. переставила, как посоветовали. не вышло

    Вы пробовали удалить все плагины? Не помогло?

    нет.плагины не удаляла. побоялась (а что, можно все удалить,потом их же установить?). …сегодня проверила совместимость рнр, т.к. была выявлена ошибка «обновить рнр».установила плагин Compatibility Checker. проверка показала: из 29 плагинов 12 только совместимы. Хотя, я устанавливала только совместимые.может дело в теме Frontier? если я ее поменяю, неполучиться, что испорчу все вообще?

    Удаляйте плагины по одному, может найдется виновник. А может и в теме дело. Попробуйте удадить и заново установить.

    Модератор Yui

    (@fierevere)

    ゆい

    https://ru.wordpress.org/plugins/health-check/

    расширенный вариант проверки Здоровья сайта,
    можно воспользоваться режимом решения проблем, для поиска проблемных плагинов, не отключая их реально (они отключаются в вашей сессии входа, можно выйти и войти в учетку снова и все вернется как было)

    также там есть и проверка совместимости плагинов с PHP

    PS: ничего удалять не надо. Раньше были рекомендации — деактивировать,
    но сейчас можно обойтись и без этого

    • Ответ изменён 2 нед. назад пользователем  Yui.

    спасибо большое. попробую ваши рекомендации.

    Доброе утро всем!
    Yui,я процитировала ваше сообщение в хостинг. пишут:
    Выполнили вызов утилиты. Её вывод — в снимке экрана.

    [code]
    curl -I https://kulinarnay-kladovay.site/wp-json/
    [/code]

    Так же Вы можете использовать веб-интерфейс для доступа к CLI сервера: Панель Управления аккаунтом TimeWeb — «SSH-консоль».
    ================================
    можете прокомментировать?

    С плагинами Вы уже разобрались? Удаляли по одному? Сейчас Ваша задача — добиться исчезновения «… class=»home blog custom-background gllr_frontier»>» вверху сайта.

Просмотр 15 ответов — с 1 по 15 (всего 44)