Поддержка Проблемы и решения Странная проблема с миниатюрами

  • Здравствуйте.

    Почти 2 года не прикасался к WordPress и вот понадобилось переделать один сайт. Скачал на локальный сервер WP 6, зашёл в адмику, работаю.

    Загружаю в пост (запись) заранее заготовленную миниатюру с нужным соотношением сторон и разрешением. И что я вижу? В медиафайлах по какой-то причине появляется дубль миниатюры с точно таким же разрешением, расширением и размером файла. Имя файла только другое (name-1.jpg). Получается, что запись выводит миниатюру под названием “name-1.jpg”, а оригинал “name.jpg” оставляет без дела.

    Собственно, вопрос: С каких пор WP стал делать копию миниатюры и почему? Как это отключить?

Просмотр 10 ответов — с 1 по 10 (всего 10)
  • Значит картинка с таким именем уже есть на сайте

    @tuxfighter такой картинки и с таким же именем нет. Проверял не раз.

    Покажу проблему более наглядно:

    Когда в WP загружаю картинку, например “cta.jpg”, то в медиафайлах появляется и “cta.jpg” (оригинал) и “cta-1.jpg” (дубль). Вот скины:

    https://disk.yandex.ru/i/EqAdFiKDsVeZ9g

    https://disk.yandex.ru/i/_tUE2S1eSfUMEA

    При чем в пост вставляется “cta-1.jpg”. приходиться лезть в медиафайлы, удалять “cta-1.jpg”, открывать пост в режиме редактирования и из медиафайлов вставлять нужный “cta.jpg” и так со ВСЕМИ картинками, что согласитесь неудобно. Как это исправить? Такого ведь раньше не было.

    Проверил проблему в других своих проетах и темах, аналогично 🙁

    • Ответ изменён 8 месяцев, 3 недели назад пользователем Shmanich.
    • Ответ изменён 8 месяцев, 3 недели назад пользователем Shmanich.

    Как это исправить?

    ну за 5 лет можно было запомнить как искать виноватого отключением плагинов и тем?

    Темы менял, плагины отключал – не помогло. 🙁

    Даже устанавливал на локальных сервер чистый WP. Когда первый раз загрузил картинку, проблемы не наблюдалось. Затем я удалил картинку и повторил тест снова. Проблема повторилась. НА ЧИСТОМ WP!

    Записал видео теста: https://disk.yandex.ru/i/0ihWgsj8dxFCrQ

    После этого теста проблема стала наблюдаться и с другими картинками: https://disk.yandex.ru/i/Wxz_bGomJKetbA

    Версия WP: 6.2.2.

    • Ответ изменён 8 месяцев, 3 недели назад пользователем Shmanich.

    я ж говорил, что файл с таким именем остался на сайте. Только не в качестве файла, а в качестве записи в БД.
    переименуй файл перед зарузкой

    @tuxfighter, переименование файла ПОМОГЛО. Однако вопросов только прибавилось:
    1. Почему в прошлых версиях WP такой проблемы не было в принципе?
    2. Что удалить в БД, чтобы загрзить файл с тем же именем после удаления прошлого? Частенько такое надо.
    2. Почему наблюдается та жа проблема у второй картинки, которая НИКОГДА не была на тестовом сайте? Видео https://disk.yandex.ru/i/Wxz_bGomJKetbA

    • Ответ изменён 8 месяцев, 3 недели назад пользователем Shmanich.
    • Ответ изменён 8 месяцев, 3 недели назад пользователем Shmanich.
    • Ответ изменён 8 месяцев, 3 недели назад пользователем Shmanich.

    1. Почему в прошлых версиях WP такой проблемы не было в принципе?

    «не сталкивался» и «не было» — разные вещи.
    В версиях 3.хх это еще было.

    2. Что удалить в БД, чтобы загрзить файл с тем же именем после удаления прошлого? Частенько такое надо.

    не знаю. для меня это поведение никогда не было проблемой.

    Почему наблюдается та жа проблема у второй картинки, которая НИКОГДА не была на тестовом сайте?

    не знаю. а картинки с таким именем точно никогда не было на сайте?

    @tuxfighter,
    «а картинки с таким именем точно никогда не было на сайте?»

    Точно. Я его сегодня сделал для записи теста.

    Закрываю вопрос, проблема исчезла сама собой.

Просмотр 10 ответов — с 1 по 10 (всего 10)
  • Тема «Странная проблема с миниатюрами» закрыта для новых ответов.