Поддержка Проблемы и решения Технические проблемы на сайте после обновления плагины Cyr-to-Lat

  • Добрый день!
    После обновления плагины Cyr-to-Lat на сайте возникли технические проблемы. Пройти в Консоль и по ссылке «режим восстановления» тоже не могу.

    Сообщение об ошибке из письма от WordPress:

    Ошибка с типом E_PARSE возникла на строке 76 файла /home/a0283042/domains/prazdnik2come.ru/public_html/wp-content/plugins/cyr2lat/includes/class-cyr-to-lat-converter.php. Сообщение об ошибке: syntax error, unexpected ‘::’ (T_PAAMAYIM_NEKUDOTAYIM)

    Подскажите, пожалуйста, что делать?

    Заранее благодарна.

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 13 ответов — с 16 по 28 (всего 28)
  • Модератор Yui

    (@fierevere)

    ゆい にゃん子

    Spectrum, они еще не успели портировать свежие баги на свой плагин. Давно вы им продались ?

    ок, залил обратно 4,0, тогда ждёмс

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    Опубликована версия 4.1.1 с исправлением.

    я перезалил только что новую версию но ни в админ панель и на сайте ни в режим восстановления не могу зайти, может стоить заменить какието-файлы на исходные?

    Мы выпустили новую версию 4.1.1 с исправлением этой ошибки прямо сейчас. Можно скачать из репозитория.

    проблема с wordpress не могу никуда зайти, плагин поставил 4.1.1,
    поэтому и спрашиваю может какие-то файлы заменить чтоб запустить сайт?

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    Оказалось, что в Cyr-To-Lat 4.1.1 проблема была исправлена не полностью, а только для PHP 5.3 и выше, хотя в readme.txt по-прежнему заявлена совместимость с PHP 5.2. Выпущена версия 4.1.2 🙂

    Если используется PHP 5.2.x — настоятельно рекомендуется повысить хотя бы до 5.6.20 (это минимальное требование в WordPress 5.2), лучше до 7.2.x или 7.3.x.

    @perdyllo, если код не трогать 10 лет — проблем не будет, но с WordPress 5+ работать не станет.

    Не ошибается тот, кто ничего не делает 😉

    что делать в моём случае? как восстановить целостность движка?

    если у вас действительно версия РНР ниже 7.0, то РНР нужно обновить.

    да поставил версию 7,2 сколько можно уже говорить??

    @oliiigor какой у вас хостер и адрес сайта? Постараемся помочь

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    проблема с wordpress не могу никуда зайти, плагин поставил 4.1.1

    Как сейчас выглядит сообщение об ошибке?

Просмотр 13 ответов — с 16 по 28 (всего 28)