Поддержка Проблемы и решения Установил ВП на VDS. Проблемы с работой админпанели

  • Здравствуйте, коллеги!
    Мы с коллегами решили перенести сайт на ВП с хостинга на выделенный сервер. Моя коллега сама занималась установкой ПО на сервере. После установки Вордпресс обнаружилась такая проблема: сама индексная страница админки загружается очень долго. После входа в админпанель все работает хорошо, кроме трех страниц. Невозможно открыть страницы Темы, Установленные плагины и Добавить новый. При попытке открыть эти страницы появляется ошибка 504 Gateway Time-out. При этом сам сайт работает нормально. Загруженную через файловый менеджер или через ftp тему удается назначить через Внешний вид — Настроить.
    Версия PHP 5.4.16, режим работы PHP — модуль Apache, оперативка 128 Мб. Ресурсов вроде бы с головой для работы ВП.
    Подскажите, кто знает, как решить данную проблему.
    Заранее всем спасибо!

Просмотр 15 ответов — с 1 по 15 (всего 30)
  • Модератор Yui

    (@fierevere)

    ゆい

    логи ошибок смотрели?

    также желательно сменить владельца /wp-content на аккаунт от которого работает apache (www-data ?)

    также проверьте чтобы были включены php расширения ( черезphpinfo() )

    [0] => Core
    [1] => date
    [2] => libxml
    [3] => pcre
    [4] => dom
    [8] => hash
    [12] => standard
    [19] => mysql
    [20] => mysqli
    [21] => mbstring
    [23] => curl
    [25] => gd
    [28] => xml
    [29] => zlib
    [30] => ctype
    [31] => gettext
    [32] => json
    [34] => iconv
    [35] => tokenizer
    [36] => zip
    [37] => imagick
    [39] => openssl

    * imagick предоставляет более высокое качество для обработки графики в редакторе wordpress, если его нет, то используется gd, впрочем некоторые плагины всегда используют gd, так что gd обязателен

    Yui, если честно, мне сообщения из журнала ни о чем не говорят. Например, есть такая запись
    Функция problems.register
    Параметры func=problems.register&
    id=postfix&
    level=warning&
    name=services.stop.problem&
    out=xml&
    param_fullname=master&
    param_service=postfix&
    sok=ok
    Связано ли это сообщение с той проблемой, которая у меня возникает с админкой?

    Модератор Yui

    (@fierevere)

    ゆい

    оперативка 128 Мб.

    надеюсь это не память сервера (сейчас таких vps уже нет), а память PHP

    id=postfix&

    это от МТА
    вам нужен error.log вебсервера, уж не знаю где он у вас живет, скорее всего в /var/log/apache2 , но т.к. поставленый коллегой дистрибутив вы не назвали, то остается только догадываться

    Yui, вот можете посмотреть информацию о конфигурации сервера http://around.pet/info.php

    Модератор Yui

    (@fierevere)

    ゆい

    не нашла ничего криминального в конфигурации

    разве что

    также желательно сменить владельца /wp-content на аккаунт от которого работает apache (www-data ?)

    вот эту рекомендацию обнуляем, т.к. у вас mod_fcgid , а не mod_php

    так что возвращаемся к тому чтобы смотреть логи ошибок

    Вот, что показывает лог ошибок при попытке открыть страницу с установленными алагинами
    2016/04/05 07:14:30 [error] 56956#0: *3609 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 37.53.156.187, server: around.pet, request: «GET /wp-admin/plugins.php HTTP/1.1», upstream: «http://127.0.0.1:8080/wp-admin/plugins.php», host: «around.pet», referrer: «http://around.pet/wp-admin/widgets.php»
    Аналогично и при обращении к странице Темы и Установить новый (плагин)

    Модератор Yui

    (@fierevere)

    ゆい

    интересно почему оно зависает, на скрипты у вас выделено 100 секунд

    define('WP_HTTP_BLOCK_EXTERNAL', true);

    а вот такое написать в wp-config.php (где нибудь перед другой инструкцией define)

    не поможет открытию страницы? если поможет — отписывайтесь тут. это не решение, а диагностика

    фаерволл на сервере не ставили? Впечатление что запрещены исходящие соединения.

    еще есть вариант — попробовать отключить ( да, да , отключить )
    расширение curl , с учетом того что curl у вас старый (CentOS, что с него взять то?) и в старой версии есть баг с SSLv3
    если вы его отключите, то wordpress станет использовать fsockopen()
    через расширение openssl, это может сработать

    Действительно, все страницы начали открываться, как только я сделал рекомендованную Вами запись

    Модератор Yui

    (@fierevere)

    ゆい

    тогда см. выше, я подредактировала запись
    проверьте настройки фаерволла и если его нет — тогда вариант с curl

    запись из wp-config.php уберите

    Модератор Yui

    (@fierevere)

    ゆい

    curl также можно попробовать отключить через плагин
    https://ru.wordpress.org/plugins/core-control/

    CURL — Disable Transport
    https://ps.w.org/core-control/assets/screenshot-4.png?rev=1365437

    К сожалению, выключить curl не могу, так как система говорит, что это расширение включено в сборку PHP, и управлять я им не могу.
    Да, файервола на сервере нет.

    Модератор Yui

    (@fierevere)

    ゆい

    плагином выше попробуйте

    хотя есть такой момент, что обычно при проблемах с sslv3 и curl идет не таймаут соединения, а отказ с соответствующим сообщением в логах что не удалось установить соединение, таймаут более характерен для фаерволла или ином запрете на уровне сети или иногда dns

    Модератор Yui

    (@fierevere)

    ゆい

    еще хорошо бы вы с шелла (ssh) проверили возможность подключения

    например так

    curl -I https://download.wordpress.org
    
    wget -O - https://download.wordpress.org
    
    openssl s_client -connect download.wordpress.org:443

    (при успешном соединении набрать exit для выхода например)

    при успехе:
    curl
    HTTP/1.1 302 Moved Temporarily
    и другие заголовки

    wget
    код html страницы

    openssl

    Timeout : 300 (sec)
    Verify return code: 20 (unable to get local issuer certificate)

    exit
    HTTP/1.1 400 Bad Request
    Server: nginx

    Спасибо огромное за помощь!! Скачал и установил плагин. Только у меня картинка немного отличается от Вашей. У меня прописано WP_HTTP_BLOCK_EXTERNAL true в разделе HTTP Related Constants. Очевидно, это и есть блокировка внешних соединений.
    Когда я выключаю PHP Streams, у меня автоматом выключается и PHP fsockopen().
    А строки PHP HTTP Extension вовсе нет.
    Буду пробовать сейчас и с шеллом экспериментировать.
    P.S. Не сразу понял, WP_HTTP_BLOCK_EXTERNAL true — это из ВП-конфиг. Удалил — теперь нет его))

    Модератор Yui

    (@fierevere)

    ゆい

    картинка немного отличается от Вашей

    это картинка автора плагина )

    У меня прописано WP_HTTP_BLOCK_EXTERNAL true в разделе HTTP Related Constants

    нужно убрать `define(‘WP_HTTP_BLOCK_EXTERNAL’, true);
    ` из wp-config.php , это была запись для диагностики, теперь если вы хотите решить проблему — ее надо убрать

    Когда я выключаю PHP Streams, у меня автоматом выключается и PHP fsockopen().
    А строки PHP HTTP Extension вовсе нет.

    отключать там надо cURL и только, если отключаете curl — используется fsockopen() , он должен работать (если нет фаерволлов итп)

    шелл — тоже диагностика.
    И да, проблема не в ВП, а в CentOS и багнутой версии curl/libcurl в ней.
    Если конечно не в блокировках на уровне сети

Просмотр 15 ответов — с 1 по 15 (всего 30)
  • Тема «Установил ВП на VDS. Проблемы с работой админпанели» закрыта для новых ответов.