Поддержка Проблемы и решения Установка WordPress Windows PHP 5.3

  • Добрый день, уважаемые коллеги!
    Я новичок в WordPress, хотя есть опыт успешной установки под Linux в последней редакции приложения.

    Пытаюсь подобрать конфигурацию XAMPP+WP для старого ПК (Windows Vista, PHP 5.3, Apache 2.2), версию WordPress выбрал 5.1.8, следуя рекомендациям https://displaywp.com/wordpress-minimum-php-version.

    Конфигурация ПК (ноутбук):

    Windows Vista 32
    Apache 2.2 + mod_rewrite
    MySQL Server 5.0.18
    PHP 5.3.3

    Web работает (phpinfo()).
    Файл конфигурации wp-config.php настроен.
    Доступ к СУБД открыт.
    Брандмауэр выключен.

    Запуск http://localhost/wordpress/wp-admin/install.php после 15 сек работы завершается с кодом 500 без какой-либо информации об ошибке, лог apache:

    127.0.0.1 — — [22/Feb/2021:11:10:30 +0300] «GET /wordpress/wp-admin/install.php HTTP/1.1» 500 —

    Очень буду признателен за помощь.

Просмотр 15 ответов — с 1 по 15 (всего 25)
  • Начиная с версии 5.0, минимальная версия РНР 7.0.
    Сейчас рекомендуемая версия РНР 7.4

    Начиная с версии 5.0, минимальная версия РНР 7.0.

    Нет же. 5.6.20 достаточно для ядра даже для 5.6. В readme.html написано.

    для ядра

    Ключевое слово -)))
    Вот только кроме ядра есть еще темы и плагины -))

    Модератор Yui

    (@fierevere)

    ゆい

    В чем цель использовать такие древности? Если есть опыт с Linux, то установить более-менее современный дистрибутив на вашу железку вы можете.

    Вы знаете что такое «unsupported» ?
    это относится и к вашей ОС , и к ПО на котором вы пытаетесь установить WP

    ReadMe.html для данной редакции WP пишет:

    System Requirements

    PHP version 5.2.4 or higher.
    MySQL version 5.0 or higher.

    Какую версию WP могли бы посоветовать?

    Да, соглашусь, железка древняя и Линукс есть. Ну а с Windows можно как-нибудь сработать?

    Модератор Yui

    (@fierevere)

    ゆい

    https://make.wordpress.org/core/handbook/references/php-compatibility-and-wordpress-versions/

    5.1 максимально.
    Однако, вам уже было сказано, про совместимость плагинов и тем.
    Опять же, выставлять такое ископаемое в сеть — небезопасно.

    Ну а с Windows можно как-нибудь сработать?

    на ней «косынка» хорошо идет.

    Ну а с Windows можно как-нибудь сработать?

    Вероятно. А смысл? Линух будет летать там, где Виста еле-еле шевелится. Проверено на Dell Latitude 420 🙂

    Только для целей отладки. Хотелось бы подобрать конфигурацию. Нужно зарядить и Windows)). Возможно ли?

    Спасибо.

    Модератор Yui

    (@fierevere)

    ゆい

    Возможно всё,
    при вашей настойчивости и самостоятельном решении задачи.

    «Unsupported» означает именно это, т.к. никто не станет делать то же самое, что и вы для того, чтобы выяснить шевелится оно еще на ископаемом ПО или уже нет…

    PS:

    Vista вышла 14 лет назад,
    PHP 5.3 — 11 лет назад

    KDE 2 — вышла в 2000 году, т.е. в 2016 году, это было «16 лет назад», сопоставимо…

    В 2016 Путину задали вопрос «Как пропатчить KDE2 под FreeBSD?»
    так вот, вам можно процитировать его ответ —

    Используйте современное программное обеспечение

    • Ответ изменён 10 месяцев, 4 недели назад пользователем Yui.

    Путин для меня не авторитет.

    Модератор Yui

    (@fierevere)

    ゆい

    речь не о политике, а об использовании «древностей»

    кстати сам вопрос «Как пропатчить KDE 2 под FreeBSD» достаточно интересный )

    Может у WP есть какой-нибудь DEBUG-MODE, где информации будет чуть больше? Я не хочу выражать свои эмоции, но где гарантии, что система будет стартовать в других условиях. Должны быть журналы, какие-то способы трассировки, хоть что-то. Об этом и прошу совета.

    какой-нибудь DEBUG-MODE

    Отладка в WordPress

Просмотр 15 ответов — с 1 по 15 (всего 25)
  • Тема «Установка WordPress Windows PHP 5.3» закрыта для новых ответов.