Поддержка bbPress bbpress работает только в примитивном виде

  • Установленный плагин форума bbpress работает только в примтивнейшем виде, как видно на http://verenitsa.ru/forums. Видимо, проблема не в самои bbpress, хотя имеется предупреждение об отсутствии проверки совместимости с текущим WP,поскольку пытался ставить другой форум — получается такая же чушь.

    Имею
    WP version 4.9.8
    Theme Verenitsa 1.0
    PHP version 5.3.29
    bbPress version 2.5.14-6684

    Active Plugins Name and Version
    — p1 bbp style pack 3.9.6
    — p2 bbPress 2.5.14
    — p3 TinyMCE Advanced 4.8.0
    — p4 UpdraftPlus — Backup/Restore 1.15.2

    Что бы это значило? Помогите, пожалуйста.

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 6 ответов — с 1 по 6 (всего 6)
  • IMHO, проблема в теме. Если в папке с темой есть шаблоны и стили для bbpress — они явно кривые.
    Ну и версия php довольно древняя,это тоже может сказываться.

    Что касается стилей, то вроде бы подключен пакет bbp style pack 3.9.6, но проверял, его наличие ни на что не влияет. А анализ страницы форума показывает практическое отсутсвие каких-либо стилей.

    Версия php действительно древняя, но ведь не может же это привести к полному отутствию офомления?

    Со стандартной темой оформления пробовали?

    Спасибо, krioteh. Немного прояснилось. Со всеми стандартными темами форум,оказывается, работает. Но, ни одна из них меня не устраивает. Что бы такое подправить в родной, дабы заставть форум с ней работать?

    Это довольно обширная тема для беседы, я полагаю, что тему нужно будет поправить в очень многих местах, дабы она поддерживала хотя бы основной функционал WordPress. Могу посоветовать только кодекс https://codex.wordpress.org/Создание_тем — сравните примеры со своей темой и так найдёте в чём «затык».

    Спасибо, друг!

Просмотр 6 ответов — с 1 по 6 (всего 6)