Поддержка Плагины Cyr to Lat enhanced — планируется ли обновление?

  • Этот плагин не обновлялся больше двух лет. Скорее всего, он уже не поддерживается и может быть несовместим с текущими версиями WordPress.

    Последнее обновление 3 года назад. Пишу на форуме поддержки, а не на странице плагина, т.к. один из авторов плагина — Сергей Бирюков (@sergeybiryukov) — является модератором на данном форуме. Надеюсь, он заметит эту тему и обновит плагин, если это требуется или подтвердить совместимость с последней версией WordPress.

    Не знаю у кого как, но у меня давно не обновляемые плагины вызывают сожаление и небольшое подозрение в плане безопасности 🙂

Просмотр 15 ответов — с 1 по 15 (всего 29)
  • Модератор Yui

    (@fierevere)

    ゆい

    посмотрите код, там менять особенно нечего, как и в «плане безопасности»
    cyr3lat обновить можно только ради того чтобы убрать плашку о том что он такой уже больше 2 лет, есть другие варианты плагина cyr to lat, там есть кое-какие проблемы которые надо исправить (не связано с безопасностью)

    Последнее обновление 3 года назад

    «Старый конь — борозды не портит» — гласит народная мудрость.

    Плагин Cyr to Lat enhanced — тот самый плагин, который лично я ставлю в первую очередь при создании любого нового сайта. Он действительно прекрасно работает. Как впрочем и многие другие «старички» уверенно выполняют свои функции, и никак не усугубляют ситуацию с безопасностью, или иными угрозами сайту, не смотря на устрашающие надписи про «давно не обновлявшиеся\возможно несовместимые». Эта надпись действительно настораживает и заставляет отказываться от установки таких плагинов. Тем более после постоянно возникающих на этом форуме обсуждениях об опасности установки устаревших тем, плагинов, версий WP.

    Поэтому целиком и полностью поддерживаю идею Yui в том что такие устаревшие, но работающие, и не несущие каких либо угроз плагины надо обновлять хотя бы чисто формально — для удаления предупреждения о «давно не обновлялся». И в первую очередь это касается именно Cyr to Lat enhanced. Неужели это так трудно?

    ПОЧТИ ОФТОП Я сейчас уже не пользуюсь, но когда то использовал хороший плагин, но ставший рекордсменом, притчей во языцех по частоте обновлений — он обновлялся чуть ли не ежедневно… Причем совершенно непонятно что именно в нем обновлял его автор, так как абсолютно никаких глюков и изменений в его работе никогда не наблюдалось.
    Это плагин https://ru.wordpress.org/plugins/yuzo-related-post/ Сейчас смотрю висит «объявление». что последнее обновление у него было 3 недели назад. Но тот, кто им пользовался ранее должны подтвердить мои слова..)))))

    • Ответ изменён 2 года, 2 месяца назад пользователем O.
    • Ответ изменён 2 года, 2 месяца назад пользователем O.
    • Ответ изменён 2 года, 2 месяца назад пользователем O.
    • Ответ изменён 2 года, 2 месяца назад пользователем O.
    • Ответ изменён 2 года, 2 месяца назад пользователем O.
    • Ответ изменён 2 года, 2 месяца назад пользователем O.
    Модератор Yui

    (@fierevere)

    ゆい

    но когда то использовал хороший плагин, но ставший рекордсменом, притчей во языцех по частоте обновлений — он обновлялся чуть ли не ежедневно

    я подумала про yuzo…

    Это плагин https://ru.wordpress.org/plugins/yuzo-related-post/

    и точно

    я перестала им пользоваться после того, как автор приделал музычку в админку,
    после этого я просто сделала функцию похожих записей кодом в теме.. и забыла про подобное «плагинотворчество»

    PS
    лучше бы локализацию подготовил
    https://translate.wordpress.org/projects/wp-plugins/yuzo-related-post
    смотрю что до сих пор не осилено им..

    • Ответ изменён 2 года, 2 месяца назад пользователем Yui.

    Несомненно, если код отвечает последним стандартам WordPress, то ничего принципиально менять не нужно, а вот отметку о совместимости с последней версией не помешало бы поставить. Обновить, так сказать, для успокоения наших душ 🙂

    Жаль, что мы так и не услышали Начальника Транспортного Цеха. ((

    to @sergeybiryukov — а вот из принципа, не обновляйте!
    (вот сейчас — я совершенно серьезно)

    wpgear, почему же не обновлять, в чем фишка, какой принцип? 😀

    to @webliberty
    не скажу. Из принципа!

    Модератор Denis Yanchevskiy

    (@denisco)

    WordPress-разработчик, wpcute.ru

    Обновить, так сказать, для успокоения наших душ 🙂

    Жаль, что мы так и не услышали Начальника Транспортного Цеха. ((

    Я так и не понял зачем вам Сергей, чтобы обновить плагин. Создайте свой и используйте его. Код же открыт и его там не так много.

    Активных установок: 100 000 — и все эти пользователи должны писать свой плагин?

    Активных установок: 100 000 — и все эти пользователи должны писать свой плагин?

    а вы думаете, что кого-то колышет сообщение об «устаревшем» плагине?

    Модератор Denis Yanchevskiy

    (@denisco)

    WordPress-разработчик, wpcute.ru

    Активных установок: 100 000 — и все эти пользователи должны писать свой плагин?

    Как связаны 100 000 пользователей и Ваш вопрос?
    Все пользователи вольны делать что хотят: пользоваться тем что есть, писать своё или не пользоваться вовсе.

    P.S. Cyr to Lat enhanced — это форк плагина Сергея Cyr-To-Lat. Не уверен, что у него вообще есть доступ к коду Cyr to Lat enhanced чтобы его обновить 😉

    P.S. Cyr to Lat enhanced — это форк плагина Сергея Cyr-To-Lat. Не уверен, что у него вообще есть доступ к коду Cyr to Lat enhanced чтобы его обновить 😉

    есть — его в контрибьютеры добавили.
    только вот на кой черт ему обновлять один из форков, когда он может обновить оригинал?
    я вот пользуюсь оригиналом и никакие cyr3lat, cyr2lat enchanced мне на фиг не сдались.

    я вот пользуюсь оригиналом

    rustolat?
    Он не транслитерирует имена файлов и ещё вроде есть проблемы с нек сочетаниями. Как, впрочем, и у cyr2lat. В cyr3lat (который и есть «Cyr to Lat enhanced») этих проблем нет.

    есть — его в контрибьютеры добавили.

    🙂
    https://ru.wordpress.org/support/topic/cyr-to-lat-%d0%b7%d0%b0%d0%b1%d1%80%d0%be%d1%88%d0%b5%d0%bd/#post-148110

    Новый год к нам мчится, «скоро» всё случиться 🙂

    и все эти пользователи должны писать свой плагин?

    Ну кому глаза муляет — может воспользоваться актуальными на сегодня альтернативами. https://ru.wordpress.org/plugins/wp-translitera/ напр

    а вы думаете, что кого-то колышет сообщение об «устаревшем» плагине?

    Конечно! И считаю это абсолютно правильным!

    Новый год к нам мчится, «скоро» всё случиться 🙂

    Да уж 🙂 В итоге исходник то уж 7 лет как не обновлялся)

Просмотр 15 ответов — с 1 по 15 (всего 29)
  • Тема «Cyr to Lat enhanced — планируется ли обновление?» закрыта для новых ответов.