• Решено andreisuharev

    (@andreisuharev)


    Здравствуйте. Я делаю тему с custom -post — type . Ситуация следующая. Уже есть какое-то количество записей, которое отображается как следует подгружая скрипт из single-name.php, но с определенного момента, все новые записи перестали подгружать single-name.php , вместо этого подгружается archive-name.php и в тоже время все предыдущие записи отображаются через single-name.php. Суть такова: Новые записи отображаются подгружая не тот скрипт, а сделанные ранее — отображаются подгружая правильный скрипт. В технологии добавления и отображения ничего не менял . С чем это может быть связано? Я заметил , что в базе данных инкремент достиг 1000 значение после чего это начало происходит . Точно ли это начало происходить на 1001-ой или 1000-ой записи сказать не могу, но я сразу подумал о каком-то встроенном процессе движка, который на этой отметке , что то делает. Теряюсь в догадках. Help. Sos. Заранее спасибо

Просмотр 4 ответов — с 1 по 4 (всего 4)
  • Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    Новые записи отображаются подгружая не тот скрипт, а сделанные ранее — отображаются подгружая правильный скрипт.

    Как выглядят ссылки на старую и новую запись?

    Предполагаю, что в структуре ссылок присутствует ID записи, а четыре цифры интерпретируются уже не как ID, а как год, и подгружается шаблон архива.

    http://mysite.com.ua/projects/1018/ ..

    Возможно вы правы. А как это возможно исправить?

    Да. При изменении названия работает . Вопрос в том как мне сделать, чтобы при формировании новой ссылки на запись , в этом процессе участвовал не только инкремент?

    Поменял ссылки — работает. Спасибо!

Просмотр 4 ответов — с 1 по 4 (всего 4)
  • Тема «Вместо single-name.php начал подгружаться archive-name.php» закрыта для новых ответов.