Поддержка Проблемы и решения is_readable() [function.is-readable]: open_basedir restriction in effect

  • Переехал на новый хостинг.
    На всех страницах сайта, и в админке, и иногда ещё повторяется, вот такая надпись:
    Warning: is_readable() [function.is-readable]: open_basedir restriction in effect. File(/home/grawlru/domains/grawl.ru/public_html/wp-content/themes/K2/styles/functions.php) is not within the allowed path(s): (/home/grawl/:/tmp:/usr/local/lib/php/) in /var/home/grawl/domains/grawl.ru/public_html/wp-content/themes/K2/app/classes/styles.php on line 24
    До этого ничего неверного в этом файле не было — по крайней мере, не ругалось. Может, это у хостера чего?

Просмотр 6 ответов — с 1 по 6 (всего 6)
  • Модератор Юрий

    (@yube)

    Смотрите внимательно:
    1. /home/grawlru/
    2. /home/grawl/

    Видите разницу? Похоже, где-то в базе сохранился абсолютный путь к файлам со старого хостинга.

    Ок, допустим, что это так. Как это лечить? Через какую-нибудь «быструю замену» в phpMyAdmin? Вопрос глупый — понимаю, но я в phpMyAdmin умею только импорт-экспорт и немного понимаю, за что какие таблицы отвечают. Посты, например, знаю, где лежат, комментарии… Но с этим боюсь накосячить. Поможете?

    Так. Кажется, надо переустановить тему K2. Дело в том, что я активировал тему WordPress Default — и ошибки не стало. Потом активировал K2 — и снова оно… оно и к лучшему: я давно не обновлял K2.

    Мм, что-то не получается.
    Вот, что я сделал:

    1. Удалил в админке тему специальной кнопкой.
    2. От темы осталась папка в /wp-content/themes/ — удалил её.
    3. В плагине WP-Optimize выбрал пункт «Optimize database tables» и нажал кнопку «Process» — попытка не пытка.
    4. Через админку установил новый K2 из репозитория.

    Всё равно ошибка. =\
    Я только-что заметил, что в разделе Внешний Вид → K2 Options ещё одна ошибка:

    The directory: /home/grawlru/domains/grawl.ru/public_html/wp-content/themes/K2/styles, needed to store custom styles is missing. For you to be able to use custom styles, you need to add this directory.

    Хотя папка-то есть такая…
    Только-что заметил, что в ошибке написано K2 (K большая), а на FTP лежит папка k2 (k маленькая). Исправил регистр буквы (удалил k из названия папки, нажал Enter, дописал K, нажал Enter). Обновляю страницу опций K2 — и вижу надпись «У Вас нет доступа к этой странице». Замечательно. Зашёл в корневую страницу админки — всё нормально. Увидел, что тема неактивна. Потому и не пустило в настройки K2, она ведь отключена. Включил тему. Вылезла снова эта ошибка сверху страницы.
    Бли-и-и-и-ин…
    Так, ок. Пока займусь своей системой и активирую дефолтную тему, чтобы нормально всё было. Но я жду ответа. Пожалуйста.

    Модератор Юрий

    (@yube)

    Я не уверен, что wp-optimize удаляет сиротливые опции. Я в свое время использовал для чистки плагин Clean Options. Удалите полностью К2. Удалите все её опции. Поставьте с нуля.

    Спасибо, помогло.

Просмотр 6 ответов — с 1 по 6 (всего 6)
  • Тема «is_readable() [function.is-readable]: open_basedir restriction in effect» закрыта для новых ответов.