Поддержка Проблемы и решения Parse error: syntax error, unexpected ‘.’, expecting ‘&’ or T_VARIABLE

  • Добрый день. Загрузил движок на денвер. Но при переходе по нужной ссылке появляется данная ошибка: Parse error: syntax error, unexpected ‘.’, expecting ‘&’ or T_VARIABLE in Z:\home\macrosmart-premium.ru\www\wp-includes\functions.php on line 1086
    Может быть я допустил, какую то ошибку?

Просмотр 3 ответов — с 1 по 3 (всего 3)
  • Может быть я допустил, какую то ошибку?

    Да, вот эту : Загрузил движок на денвер

    Модератор Yui

    (@fierevere)

    ゆい

    у вас на вашем антикварном денвере какая версия PHP?
    Он давно вроде уже не обновляется и классифицируется как ископаемая древность, оставьте его археологам. Поставьте что-то с современной версией PHP, 7.2 хотя бы.

    А лучше используйте хостинг, там уже многие проблемы решены, а так еще <yoda>много граблей разложенных ожидают вас.</yoda>

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    Загрузил движок на денвер.

    В Денвере версия PHP — 5.3.13, WordPress требует 5.6.20 или выше (рекомендует 7.4 или выше).

    при переходе по нужной ссылке появляется данная ошибка: Parse error: syntax error, unexpected ‘.’, expecting ‘&’ or T_VARIABLE in Z:\home\macrosmart-premium.ru\www\wp-includes\functions.php on line 1086

    Нужная ссылка — это какая?

    На чистой установке не удалось воспроизвести, выдаётся корректное сообщение: «Your server is running PHP version 5.3.29 but WordPress 5.5.3 requires at least 5.6.20».

Просмотр 3 ответов — с 1 по 3 (всего 3)