• Решено artemhp

    (@artemhp)


    В админке. В разделе Permalink Settings переключил настройки на Month and name.
    Ссылка прописались красиво: /2010/12/безшумний-компютер-апаратна-частина
    но, когда нажимаю на ссылку, выдает ошибку.

    The requested URL /2010/12/безшумний-компютер-апаратна-ча�тина/ was not found on this server.

    в .htaccess

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d

Просмотр 10 ответов — с 1 по 10 (всего 10)
  • не пробовали поставить rus-to-lat или cyr-to-lat?
    поискать по форуму на тему «русские символы в URL»

    Автор artemhp

    (@artemhp)

    нет такие плагины не стоят. мне интересно что бы ссылки были кириллические

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    А если попробовать строки со страницы «Проблема с кодировкой»?

    Автор artemhp

    (@artemhp)

    Странно, теперь шаблон работает, но отображается
    Error 404 — Not Found

    походу подключается 404.php
    Как диагностировать?

    Автор artemhp

    (@artemhp)

    на счет моей ошибки, то я не до конца копипаснул код в htaccess

    AddDefaultCharset utf-8
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    Стоит выполнить пункты 4—6.

    P.S. Будет здорово если вы посмотрите, какие из ваших предыдущих вопросов можно считать решёнными.

    Автор artemhp

    (@artemhp)

    RusToLat отключил — заработало. большое спасибо

    > P.S. Будет здорово если вы посмотрите, какие из ваших предыдущих вопросов можно считать решёнными.
    Спасибо за замечание, сейчас займусь

    Пожалуй продолжу тему.
    Шаблонизатор не подхватывает файл page.php, когда нажимаю на страницу созданную в админке под разделом «Pages»

    Когда именую ссылку в «Pages» латиницей «/about», то работает, а если кириллицей — «/про-блог» то бросает на страницу шаблона index.php

    Отключил все плагины — толку ноль

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    спасибо, помогло

Просмотр 10 ответов — с 1 по 10 (всего 10)
  • Тема «Permalink Settings» закрыта для новых ответов.