Поддержка Плагины PHP Compatibility Checker не может отсканировать все плагины сайта

  • Здравствуйте! При попытке отсканировать плагины сайта на совместимость с последней версией php напротив многих из них выдается сообщение «Плагин / тема была пропущена, так как она была слишком большой для сканирования, прежде чем сервер убил процесс». Подскажите пожалуйста, есть ли еще возможность проверить их на совместимость? Может какие нибудь настройки надо поменять?

Просмотр 9 ответов — с 1 по 9 (всего 9)
  • Модератор Yui

    (@fierevere)

    ゆい にゃん子

    max_execution_time в настройках PHP, если у вас 30 сек, то этого мало, рекомендуется установить большее значение

    Спасибо за ответ, но к сожалению, я не очень хорошо разбираюсь в теме, поэтому для меня загадка где меняются эти настройки. На хостинге или это можно сделать через админку ворд пресса? Может подскажете?

    Модератор Yui

    (@fierevere)

    ゆい にゃん子

    на хостинге, где это можно сделать поточнее — можно/нужно узнавать в техподдержке хостинга

    Только что погуглила. Это делается на хостинге в папке php.ini. Допустим изменю я его на 60 с. Потом обратно изменять настройки или так оставить?

    Модератор Yui

    (@fierevere)

    ゆい にゃん子

    гулить не стоило, вариантов настройки может быть много, лучше спросить ТП хостинга.

    Настройки назад можно не менять, 60-90 секунд в принципе — рекомендуемое значение.

    Спасибо! Буду пробовать.

    Доброе утро! Увеличение времени max_execution_time до 300 с прибавило 1 отсканированный плагин. Большинство так и осталось не отсканированными. До какого предельного значения можно это время увеличивать?

    Модератор Yui

    (@fierevere)

    ゆい にゃん子

    5 min это очень прилично, скорее всего что-то пошло не так со сканером и он на чем-то зависает.

    А для чего вы производите проверку? Для обновления PHP?

    Поставьте https://ru.wordpress.org/plugins/health-check/
    там есть проверка совместимости плагинов с PHP (для самого HealthCheck может показываться совместимость только с PHP 5.6, это нормально)

    Либо можно переключиться на более высокую версию PHP без проверки,
    если что-то пойдет не так — вы увидите это в журнале ошибок, узнайте где у вас логи ошибок PHP на хостинге лежат.

    Спасибо за помощь!

Просмотр 9 ответов — с 1 по 9 (всего 9)