Поддержка Плагины Subscribe to Comments Reloaded: не работает подтверждение

  • Примерно год назад в плагине Subscribe to Comments Reloaded перестало работать подтверждение подписки, по времени это примерно совпало со сменой владельца плагина, наверное что-то изменили. Пришлось удалить плагин на тот момент.

    Сейчас вновь пробую установить и настроить плагин. Все тоже самое, включена опция двойного подтверждения подписки, письмо на почту со ссылкой подтверждения приходит, но при переходе получаю сообщение:

    Ни одна подписка не соответствует поисковому запросу

    Может кто-нибудь сталкивался с такой проблемой? На тестовом сайте все прекрасно работает, не могу выяснить причину почему не работает на рабочем сайте.

Просмотр 7 ответов — с 1 по 7 (всего 7)
  • Попробуйте AnyComment, там есть подписка на комментарии, настройка дизайн, целая экосистема для комментариев.

    Заметил, что уникальный ключ StCR в настройках плагина и в ссылке подтверждения почему-то не совпадают (не знаю, должны ли).

    На странице управления подписками нет ни единой записи, даже неподтвержденных.

    В логах сервера ошибка:

    [Mon Apr 06 15:34:59 2020] [warn] [client 178.69.219.61] mod_fcgid: stderr: \xd0\x91\xd0\xb0\xd0\xb7\xd0\xb0 \xd0\xb4\xd0\xb0\xd0\xbd\xd0\xbd\xd1\x8b\xd1\x85 WordPress \xd0\xb2\xd0\xbe\xd0\xb7\xd0\xb2\xd1\x80\xd0\xb0\xd1\x82\xd0\xb8\xd0\xbb\xd0\xb0 \xd0\xbe\xd1\x88\xd0\xb8\xd0\xb1\xd0\xba\xd1\x83 Illegal mix of collations (utf8mb4_unicode_520_ci,IMPLICIT) and (utf8mb4_unicode_ci,IMPLICIT) for operation ‘=’ \xd0\xb2 \xd0\xbe\xd1\x82\xd0\xb2\xd0\xb5\xd1\x82 \xd0\xbd\xd0\xb0 \xd0\xb7\xd0\xb0\xd0\xbf\xd1\x80\xd0\xbe\xd1\x81 SELECT meta_id, REPLACE(meta_key, ‘_stcr@_’, ») AS email, post_id, SUBSTRING(meta_value, 1, 19) AS dt, SUBSTRING(meta_value, 21) AS status, srs.subscriber_unique_id AS email_key

    Что-то со сравнением таблиц базы данных?

    На тестовом, где все работает сравнение: utf8mb4_unicode_520_ci
    На котором не работает сравнение: utf8mb4_unicode_ci

    Конвертировал все таблицы базы данных в кодировку utf8mb4 сравнение utf8mb4_general_ci и наконец-то все заработало 😉

    Проблема была с AnyComment или Subscribe плагином?

    Тема была создана про Subscribe to Comments Reloaded, как оказалось, проблема была в кодировке или сравнении базы данных.

    AnyComment не устанавливал.

Просмотр 7 ответов — с 1 по 7 (всего 7)