Поддержка Проблемы и решения Uncaught ReferenceError: commonL10n is not defined

  • Решено igramnet

    (@igramnet)


    Вот такая проблема на чистом wordpress. Конфиг nginx плохой или что не так? На 5.4 всё ок было.

    common.min.js?ver=5.5.3:2 Uncaught ReferenceError: commonL10n is not defined
        at HTMLDocument.<anonymous> (common.min.js?ver=5.5.3:2)
        at HTMLDocument.dispatch (load-scripts.php?c=0&load[chunk_0]=jquery-core,utils&ver=5.5.3:3)
        at HTMLDocument.r.handle (load-scripts.php?c=0&load[chunk_0]=jquery-core,utils&ver=5.5.3:3)
        at Object.trigger (load-scripts.php?c=0&load[chunk_0]=jquery-core,utils&ver=5.5.3:3)
        at HTMLDocument.<anonymous> (load-scripts.php?c=0&load[chunk_0]=jquery-core,utils&ver=5.5.3:3)
        at Function.each (load-scripts.php?c=0&load[chunk_0]=jquery-core,utils&ver=5.5.3:2)
        at n.fn.init.each (load-scripts.php?c=0&load[chunk_0]=jquery-core,utils&ver=5.5.3:2)
        at n.fn.init.trigger (load-scripts.php?c=0&load[chunk_0]=jquery-core,utils&ver=5.5.3:3)
        at Q (common.min.js?ver=5.5.3:2)
        at HTMLDocument.<anonymous> (common.min.js?ver=5.5.3:2)
Просмотр 15 ответов — с 1 по 15 (всего 19)
  • anonymized-14765447

    (@anonymized-14765447)

    igramnet, привет.

    Может помочь очистка кэша браузера.

    Автор igramnet

    (@igramnet)

    5.5.3 сейчас

    Автор igramnet

    (@igramnet)

    Чистка не помогла
    Пробовал в инкогнито

    anonymized-14765447

    (@anonymized-14765447)

    igramnet, я так понял, что это результат работы хотфикса, начиная с версии 5.5.1:

    Added a patch which cleanly deprecates the l10n object getters, throws a console error and returns an empty string whenever a deprecated getter is called.

    Автор igramnet

    (@igramnet)

    Я установил чистый WordPress и получил ошибку.

    anonymized-14765447

    (@anonymized-14765447)

    igramnet, я это понял с первого раза, а вы мой ответ, видимо, нет.

    Автор igramnet

    (@igramnet)

    Так что за хотфикс? И как это исправить?

    Модератор Yui

    (@fierevere)

    ゆい

    а тема какая на вашем «чистом» WordPress?

    Автор igramnet

    (@igramnet)

    Пробовал любую

    Twenty Twenty
    Twenty Nineteen
    Twenty Seventeen

    ошибка везде 🙁 Причём сборка на локале работает успешно.

    Модератор Yui

    (@fierevere)

    ゆい

    define('CONCATENATE_SCRIPTS', false);

    в wp-config.php попробуйте добавить

    anonymized-14765447

    (@anonymized-14765447)

    igramnet, сборка?

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    я так понял, что это результат работы хотфикса

    Результат работы хотфикса — сообщение следующего вида вместо ошибки:

    
    commonL10n.warnDelete is deprecated since version 5.5.0! Use wp.i18n instead.
    

    И как это исправить?

    Ошибка Uncaught ReferenceError: commonL10n is not defined у меня на чистой установке не воспроизводится. Если установить версию 5.5.3 и затем скопировать файл wp-admin/js/common.min.js от 5.4 — тогда да, есть похожее сообщение.

    Для начала стоит убедиться, что все файлы успешно обновлены.

    Автор igramnet

    (@igramnet)

    1. Скачать https://ru.wordpress.org/latest-ru_RU.zip (на момент поста это 5.5.3)
    2. Распаковал и установил всё с нуля. При первом входе вот ошибка
    https://pixs.ru/image/7D44k

    Чем все закончилось? У меня тоже самое на чистой установке…

    • Ответ изменён 1 год, 11 месяцев назад пользователем demaun.

    @demaun, ничем. Я так и не смог побороть ошибку. Всё ещё ищу решение. Копия сайта на локале работает без ошибок. Ерунда какая-то.

Просмотр 15 ответов — с 1 по 15 (всего 19)
  • Тема «Uncaught ReferenceError: commonL10n is not defined» закрыта для новых ответов.