Поддержка Проблемы и решения /wp-includes/blocks.php on line 253

  • ошибка /wp-includes/blocks.php on line 253 кто-нибудь сталкивался и как решили?

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 15 ответов — с 1 по 15 (всего 22)
  • Модератор Yui

    (@fierevere)

    ゆい

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    Ошибка связана с параметром mbstring.func_overload в php.ini, должна быть исправлена в одной из следующих версий: https://github.com/WordPress/gutenberg/issues/13655.

    Никаких плагинов не стоит… шаблон штатный… пишет эту ошибку… ничего не делал ни где ни лазил… PHP Version 7.0.15, WordPress 5.2.3., mbstring.func_overload в php.ini стоит 0

    • Ответ изменён 1 месяц назад пользователем  uralb.
    • Ответ изменён 1 месяц назад пользователем  uralb.

    Хостер написал… данная проблема противоречит логике сайта… Помогите пожалуйста!

    • Ответ изменён 1 месяц назад пользователем  uralb.

    переключитесь на php 7.2-7.3, должно помочь.

    обновился до 7.1.32, не помогло….

    переключитесь на php 7.2-7.3
    и
    обновился до 7.1
    найдите одно различие

    у меня на сервере еще битрикс веб окружение… была возможность обновится только до этой версии

    Модератор Юрий

    (@yube)

    еще битрикс

    Требования Битрикса к php, в частности mbstring.func_overload=2, несовместимы с жизнью с большинством движков. Ищите способ отсадить его на другое окружение php.

    Юрий такая проблема не только у меня… многие сталкиваются… она признана и этот баг в последующих обновлениях должен быть исправлен, но временное решение должно же быть?

    Модератор Юрий

    (@yube)

    в последующих обновлениях должен быть исправлен

    Движка. Но есть еще темы и плагины, которые также могут спотыкаться об эту противоестсественную настройку. Поэтому я считаю единственно правильным решением создание отдельных сред обитания для Битрикса и для нормальных движков.

    Пока что речь идет только об этой проблеме…. подскажите лучше решение этой проблемы

    Модератор Yui

    (@fierevere)

    ゆい

    решение вам уже подсказали

    Требования Битрикса к php, в частности mbstring.func_overload=2, несовместимы с жизнью с большинством движков.

    для WP требуется установить mbstring.func_overload=0
    иначе проблемы могут вылезать в самых неожиданных местах, они конечно отлавливаются и понемногу исправляются, но вам никто не гарантирует, что не вылезут где-то новые.
    Решением вашей проблемы будет разнести настройки PHP для разных сайтов,
    для битрикса
    mbstring.func_overload=2
    для всего остального
    mbstring.func_overload=0

    как это сделать — спрашивайте техподдержку хостинга.

    подскажите лучше решение этой проблемы

    отказаться от использования битрикса и сделать нормальные настройки

    У меня сервер… для чего мне все разделять

Просмотр 15 ответов — с 1 по 15 (всего 22)