Ответы в темах

Просмотр 15 ответов — с 1 по 15 (всего 26)
  • Юху!!! Я обновил сайт. Как и в тот раз, помогло установление разрешений: для папок 755, для файлов 644. За исключением эйчтиаксесс и випи конфиг, у которых особые разрешения.

    По поводу прав на директории

    Романтично-то: директория… Вспомнилась будённовка, гражданская война, циркуляр, декрет))) «Можно» не значит, что так и есть. А вот установив некоторые плагины вполне можно автоматизировать

    Это не автоматические. Автомат — это когда обновяется само, вообще без ведома админа.

    «Можно» не значит, что так и есть. А вот установив некоторые плагины вполне можно автоматизировать сей процесс и на 5.4.

    Красивые рассуждения у бывалых программистов… Только вот никто не подскажет, как оживить сайт. Ведь если бы он был изначально ущербным, то и на предыдущих версиях не работал бы полноценно. Значит, есть второстепенный изъян, проявляющийся только при обновлении ядра. Может, это ССЛ сертификат некорректно установленный.

    Если Вы о минорных обновлениях (в последней цифре), то они должны работать у любого приемлемого хостера. Не работают — менять хостинг.

    А если о мажорных (например, с 5.4 на 5.5), то лучше не надо. Ибо чревато.

    Сейчас у меня только плагины можно обновить автоматически. Остальное — сам должен делать. Сейчас пытаюсь запустить сайт в полноценном режиме посредством назначения корректных разрешений для папок и документов Вордпресса. Там разрешения в целом правильные, но может какие-то папки или документы имеют неправильные разрешения.

    Однажды у меня так получилось оживить сайт, когда перешёл с одной версии ядра на другую и остался без админки. Поменял разрешения на папки и документы. И сайт заработал. Кстати, тогда я поменял разрешения не совсем корректно с точки зрения профессионалов, но сайт ведь заработал в полную силу, перешёл на новую версию ядра.

    @nescom, привет. Наверно, перееду. А то не совсем современная фирма сейчас оказывает мне услуги. Отвечают медленно, неохотно.

    Если есть таковые, надо перейти к тем, у кого есть автоматическое обновление ядра Вордпресса.

    И что делать с этим: Could not confirm that the wp_version_check() filter is available.

    Давайте не будем разводить филологическую дискуссию. Лучше подскажите, что делать с неисправностями в заливке фотографий и с The loopback request to your site failed

    у вас есть доступ к командной строке сервера?
    в панели хостиинга или через ssh?

    можете выполнить там команду

    curl -I https://blog.daniyar.info

    что на выдаче?

    
    'abrt-cli status' timed out
    [daniyar@host ~]$ curl -I https://blog.daniyar.info
    HTTP/1.1 200 OK
    Date: Sun, 28 Jun 2020 14:50:24 GMT
    Server: Apache
    X-Powered-By: PHP/7.2.31
    Link: <https://blog.daniyar.info/wp-json/>; rel="https://api.w.org/", <https://wp.me/4HMEm>; rel=shortlink
    Upgrade: h2,h2c
    Connection: Upgrade
    Cache-Control: max-age=600
    Expires: Sun, 28 Jun 2020 15:00:24 GMT
    Vary: Accept-Encoding,User-Agent
    Accept-Ranges: none
    Content-Type: text/html; charset=UTF-8
    
    [daniyar@host ~]$
    

    МодераторYui (@fierevere)
    ゆい

    12 минут назад
    в одной официальной англоязычной статье на Вордпрессе читал такое требование.

    И вероятно перепутали «требование» и «рекомендацию»

    Говорилось, что минимум 7.4 должно быть. Факт, что даже 7.3 на моем сайте нельзя установить.

    • Ответ изменён 2 года, 3 месяца назад пользователем kvkkvk.

    Юрий, в одной официальной англоязычной статье на Вордпрессе читал такое требование.

    По второй ошибке они говорят, что не знаимались разработкой моего сайта. Поэтому не могут помочь.

    Ещё малоприятный момент. Начиная с версии Вордпресса 5.3, пропадают некоторые фотографии, особенно по размеру больше 1 мбайта. Приходится или перезаливать их, или закачивать их на сторонние фотосервисы и делать на них ссылку в своих статьях.

    Хостеры сказали, что сам могу обновить PHP. Так и сделал. Только версия 7.2, которую поставил, тоже несвежая. Хотел было поставить 7.3, но сайт рухнул от неё. А ведь минимально требуется 7.4. Видимо, хостеры не очень современные ребята.

    Остались две критические ошибки (первая из них тоже может быть легко устранена мной, насчёт второй — сложновато).

    1) The value, WP_DEBUG_LOG, has been added to this website’s configuration file. This means any errors on the site will be written to a file which is potentially available to normal users.

    2) The loopback request to your site failed, this means features relying on them are not currently working as expected.
    Error: cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received (http_request_failed)

    А менее серьезная ошибка следующая:

    Could not confirm that the wp_version_check() filter is available.

    Ещё малоприятный момент. Начиная с версии Вордпресса 5.3, пропадают некоторые фотографии, особенно по размеру больше 1 мбайта. Приходится или перезаливать их, или закачивать их на сторонние фотосервисы и делать на них ссылку в своих статьях.

    • Ответ изменён 2 года, 3 месяца назад пользователем kvkkvk.

    alexander70, там значится:
    phpMyAdmin
    Version information: 4.9.5

    Web server
    PHP version: 7.3.6

    Yui, сделал, как вы сказали.

    VLΛD VΞCTOR, добавил ваши строчки в файл конфигурации. А вот, что написано в error_log:

    [20-May-2020 21:00:21 UTC] PHP Warning: require_once(/home/daniyar/public_html/blog.daniyar.info/wp-content/plugins/google-site-kit/includes/Core/Authentication/Authentication.php): failed to open stream: No such file or directory in /home/daniyar/public_html/blog.daniyar.info/wp-content/plugins/google-site-kit/includes/loader.php on line 34
    [20-May-2020 21:00:23 UTC] PHP Fatal error: require_once(): Failed opening required ‘/home/daniyar/public_html/blog.daniyar.info/wp-content/plugins/google-site-kit/includes/Core/Authentication/Authentication.php’ (include_path=’.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php’) in /home/daniyar/public_html/blog.daniyar.info/wp-content/plugins/google-site-kit/includes/loader.php on line 34

    Ещё вопрос. Можно ли удалить из файла конфигурации следующие строки:

    //Added by WP-Cache Manager
    require_once( dirname( __FILE__ ) . ‘/gd-config.php’ );
    define( ‘FS_METHOD’, ‘direct’);
    define(‘FS_CHMOD_DIR’, (0705 & ~ umask()));
    define(‘FS_CHMOD_FILE’, (0604 & ~ umask()));
    define(‘DISALLOW_FILE_EDIT’, TRUE);
    /* That’s all, stop editing! Happy blogging. */

    Это приложение я давно удалил.

    Yui, спасибо за совет.

    VLΛD VΞCTOR, салют.

    Удалить define(‘DISABLE_WP_CRON’, true); и добавить define(‘ALTERNATE_WP_CRON’, true);

    Впрочем, некритично. Сохранить копию сайта можно и в Cpanel.

    А по какому адресу смотреть список ошибок Вордпресса?

Просмотр 15 ответов — с 1 по 15 (всего 26)