Ответы в темах

Просмотр 10 ответов — с 1 по 10 (всего 10)
  • Нет никакой возможности применить некий хук, чтобы цифра в списке рубрик показывала не только публичные, а все записи?

    Давайте еще разок. Без картинок, на пальцах.
    Открываю список рубрик, ВП пишет что в рубрике 0 записей. Кликаю по этому самому нулю — показывает что в рубрике есть одна запись.
    Это логично? Писать «ноль» а при клике по нему показывать что записи есть?
    Почему не писать их реальное число? Я же админ, и записи я разместил — зачем от меня же скрывать их количество?

    «Баг» плагинов? Ну напишите их разработчикам, если считаете
    это багом. Или свой.

    Баг ВП, а не плагинов.

    Во-первых, я написал, что из за этого не корректно работают плагины поиска.
    А во-вторых, просто неприятно удивлен, что за последние 4 года уже привык что ВП в целом стабильная система, а тут такой откровенный на мой взгляд баг.
    Если это не баг, то я хотел услышать хоть какое-то разумное объяснение этой «фиче». И по возможности совет, как ее обойти.

    Это как, интересно?

    Ну вот ВП пишет что в рубрике 0 записей https://yadi.sk/i/MdoIx5tqi_ueKA — а там же не 0, а 1. Хоть и личная, но есть же. Я авторизован и админ — почему он не пишет мне что там 1 запись?
    Ведь вроде логично если тебе показывает, сколько тебе доступно записей, а другому сколько ему?

    Что значит «не выводится» — прекрасно выводится https://yadi.sk/i/uVTWJBqMB-sEqA
    Я админ и я должен все записи видеть и везде. А когда даже от меня скрывают мои же личные записи — это неправильно.
    У меня из за этого и плагин поиска «Ajax Search Lite» не корректно работает. Поскольку сам ВП говорит что в рубрике 0 записей, то и он за ним это повторяет. А их то не ноль.
    Неужели никого это не напрягает и нет фильтра чтобы исправить это?

    Может прочитать правила форума

    Я пишу в нужной теме. У меня тоже самое что и у ТС, если вы прочтете внимательно посты, то увидите:

    Если по делу, то у меня проблема похожая на проблему ТС, только ошибка идет не 403, а 404

    Разница в ошибке здесь не принципиальна. Проблема одна и таже — REST API.

    Так что насчет не работающей версии 4.8? Можете как-то помочь? Второй сайт делаю с чистого шаблона и все то же самое — плагин при попытке отправить форму не может найти чего-то там у себя. Ошибка 404, путь примерно такой он ищет
    /wp-json/contact-form-7/v1/contact-forms/11/feedback

    REST-API специально никак не отключал
    Что делать? Как проверить?

    В файле функций для теста вообще все стер — все то же самое. Может надо наоборот что то добавить туда?

    • Ответ изменён 2 года, 8 месяцев назад пользователем Mario62rus.

    С другой стороны на чистом тестовом сайте v4.8 работает как надо — получается дело все же в сайте. Но вот в чем именно — вопрос.

    Вариант, что люди могут что-то создавать просто из любви к искусству, вообще не рассматривается?

    Я только за созидание из любви. Просто тогда мне сложно понять почему никто из создателей плагинов не скажет «все. мы закончили с плагином. дальше будем только ошибки исправлять. пользуйтесь!». А вместо это все и так уже работающее «улучшают» и «улучшают»…

    Сайт другой. Я уже откатил к v4.7 так как не могу долго ждать решения проблемы, надо делать работу. Сайт luckytucky.ru если интересно проверить REST-API.
    Если решения с 4.8 не найдется, то подскажите хотя бы как правильно сделать русский язык, так как плаг v4.7, скачанный по ссылке выше, на англ. Возможно надо скачать чуть более свежую версию — между 4.7 и 4.8?

    Ни у кого нет ощущения, что данный плагин, как и многие другие, дорос до стадии, когда все что могли сделали, все отлично и все работает и после этого начинаются раздумья «а чтобы нам еще этакого сделать… как бы еще изголиться…». Ведь нужно выпускать новые версии и получать зарплату за работу.
    А поскольку все уже было хорошо, то дальнейшие «доработки» приводят только к проблемам и к недовольству пользователей.

    Ладно, это лирика. Если по делу, то у меня проблема похожая на проблему ТС, только ошибка идет не 403, а 404. Не найден этот путь:
    /wp-json/contact-form-7/v1/contact-forms/89/feedback
    Никакого отключения REST-API нет.
    Что делать? Может откат на 4.7 и решит проблему, но только это какое-то неправильное решение.

Просмотр 10 ответов — с 1 по 10 (всего 10)