ActiveCampaign Postmark for WordPress

Описание

If you’re still sending email with default SMTP, you’re blind to delivery problems! ActiveCampaign Postmark for WordPress enables sites of any size to deliver and track WordPress notification emails reliably, with minimal setup time and zero maintenance.

If you don’t already have a Postmark account, you can get one in minutes, sign up at https://postmarkapp.com

Check out our video on how to set up the Postmark for WordPress plugin here.

Additional Resources

Postmark for WordPress FAQ

Can I use the Postmark for WordPress plugin with Gravity Forms?

How do I send with Ninja Forms and Postmark for WordPress?

How do I send with Contact Form 7 and Postmark for WordPress?

Can I use the Postmark for WordPress plugin with Divi contact forms?

Скриншоты

  • ActiveCampaign Postmark WP Plugin Settings screen.

Установка

  1. Upload postmark directory to your /wp-content/plugins directory
  2. Activate plugin in WordPress admin
  3. In WordPress admin, go to Settings then Postmark. You will then want to insert your Postmark details. If you don’t already have a Postmark account, get one at https://postmarkapp.com
  4. Verify sending by entering a recipient email address you have access to and pressing the «Send Test Email» button.
  5. Once verified, then check «Enable» to override wp_mail and send using the Postmark API instead.

Часто задаваемые вопросы

What is Postmark?

Postmark is a hosted service that expertly handles all delivery of transactional webapp and web site email. This includes welcome emails, password resets, comment notifications, and more. If you’ve ever installed WordPress and had issues with PHP’s mail() function not working right, or your WordPress install sends comment notifications or password resets to spam, Postmark makes all of these problems vanish in seconds. Without Postmark, you may not even know you’re having delivery problems. Find out in seconds by installing and configuring this plugin.

Will this plugin work with my WordPress site?

The Postmark for WordPress plugin overrides any usage of the wp_mail() function. Because of this, if any 3rd party code or plugins send mail directly using the PHP mail function, or any other method, we cannot override it. Please contact the makers of any offending plugins and let them know that they should use wp_mail() instead of unsupported mailing functions.

TLS Version Requirements/Compatibility

The Postmark API requires TLS v1.1 or v1.2 support. We recommend using TLS v1.2.

You can check your TLS v1.2 compatibility using this plugin. After installing the plugin, change the dropdown for ‘Select API Endpoint’ to How’s My SSL? and run the test. If compatibility with TLS v1.2 is not detected, contact your server host or make the necessary upgrades to support TLS v1.1 or v1.2.

TLS 1.2 requires:

  • PHP 5.5.19 or higher
  • cURL 7.34.0 or higher
  • OpenSSL 1.0.1 or higher

Does this cost me money?

The Postmark service (and this plugin) are free to get started. You can sign up at https://postmarkapp.com/. When you need to process more email, Postmark offers monthly plans to fit your needs.

My emails are still not sending, or they are going to spam! HELP!?

No worries, our expert team can help. Just send an email to support@postmarkapp.com or tweet @postmarkapp for help. Be sure to include as much detail as possible.

Why should I trust you with my email sending?

Because we’ve been in this business for many years. Through trial and error we already know what it takes to manage a large volume of email. We handle things like whitelisting, ISP throttling, reverse DNS, feedback loops, content scanning, and delivery monitoring to ensure your emails get to the inbox.

Most importantly, a great product requires great support and even better education. Our team is spread out across six time zones to offer fast support on everything from using Postmark to best practices on content and user engagement. A solid infrastructure only goes so far, that’s why improving our customer’s sending practices helps achieve incredible results

Why aren’t my HTML emails being sent?

This plugin detects HTML by checking the headers sent by other WordPress plugins. If a «text/html» content type isn’t set then this plugin won’t send the HTML to Postmark to be sent out only the plain text version of the email.

How do I set environment specific Postmark plugin settings?

You can optionally set the Postmark API Token, message stream, and default sending address by adding the following to your wp-config.php file:

`

define( ‘POSTMARK_API_KEY’, » );
define( ‘POSTMARK_STREAM_NAME’, ‘stream-name’ );
define( ‘POSTMARK_SENDER_ADDRESS’, ‘from@example.com’ );
`

Setting any of these here will override what is set via the plugin’s UI.

Why are password reset links not showing in emails sent with this plugin?

There are a couple ways to resolve this issue.

  1. Open the Postmark plugin settings and uncheck Force HTML and click Save Changes. If the default WordPress password reset email is sent in Plain Text format, the link will render as expected.

  2. Access your WordPress site directory and open the wp-login.php file.

Change this line:

    $message .= ‘<‘ . network_site_url(“wp-login.php?action=rp&key=$key&login=” . rawurlencode($user_login), ‘login’) . “>\r\n”;

Remove the brackets, so it becomes:

    $message .= network_site_url(“wp-login.php?action=rp&key=$key&login=” . rawurlencode($user_login), ‘login’) . “\r\n”;

And save the changes to the file.

How do I set the from name?

The plugin supports using the wp_mail_from_name filter for manually setting a name in the From header.

I also need a marketing automation tool to connect to my WordPress site. What do you recommend?

At ActiveCampaign you’ll find the email marketing, marketing automation, and CRM tools your marketing and sales teams will love. ActiveCampaign integrates seamlessly with your WordPress site so you can embed forms and collect email addresses on any page, track website visits (and then use that information to trigger automated follow-up emails), or enable live chat to engage with your visitors in real time. Learn more about ActiveCampaign for WordPress.

Отзывы

17.06.2022
I've tried all sorts of email delivery services and Postmark makes all the others look like amateurs. Especially SendGrid -- they are horrible. But I digress, that is for a different discussion. I've been using Postmark for over a year now and it's been a great experience.
21.01.2022
Months after flagging with Postmark, this plugin is still useless. It's pot luck if the option will appear under Settings. Have tried on multiple different environments and almost every time it doesn't appear.
22.10.2021
I am a developer but I interact with a lot of people who can't be bothered by dev things. The Postmark service seems robust, but as far as WordPress is concerned, I find people like it when they can easily do the one "magic" thing they expect it to. Punching some stuff in a field, and having nice short stubby screens to fill out essentially one time? That's super client friendly. Even doing the DNS is quick and zippy and it's all laid out nice. It delivers, and fast, but one of the things that blew my mind was the support. Every day I see more and more companies resorting to third-party entities to handle customer service, even if they didn't use to. Often the bigger companies go with the cheapest option, which isn't thinking in the long term because even though everyone's speaking or writing English, nothing is being understood. I hadn't even bought anything and had a question about something, and I got an email back in an hour with no form-letter crap, clearly tailored to what I had asked and the way I asked it. Couple paragraphs, well-written -- and with no attitude even though the entire time I had whiffed on noticing that their site had the answer in one of their equally-nice educational articles the whole time. I know the support isn't on the repository, just the code, but I am sharing it not for sunshine's sake but because email is a huge deal for people and the idea that you have a safety net might be useful for people considering. Happy to edit the review to kill the language if that's inappropriate.
05.11.2020 1 ответ
The wordpress plugin is not compatible with any wordpress version, as I used the latest one and the old one on both no plugin settings shown at backend. Test your plugin with all wordpress versions before writing tested upto 5.5.3 version. Worst plugin | Compatibility Issues
Посмотреть все 25 отзывов

Участники и разработчики

«ActiveCampaign Postmark for WordPress» — проект с открытым исходным кодом. В развитие плагина внесли свой вклад следующие участники:

Участники

Перевести «ActiveCampaign Postmark for WordPress» на ваш язык.

Заинтересованы в разработке?

Посмотрите код, проверьте SVN репозиторий, или подпишитесь на журнал разработки по RSS.

Журнал изменений

v1.17.2

  • Fix Site Health constants usage.

See the previous changelogs here