Требования

Чтобы использовать WordPress, мы рекомендуем использовать хостинг, который поддерживает:

  • PHP версии 7.2 или выше.
  • MySQL версии 5.6 или выше ИЛИ MariaDB версии 10.0 или выше.
  • HTTPS

Это действительно так. Мы рекомендуем Apache или Nginx как самый надежный и функциональный сервер для запуска WordPress, но сойдет и любой сервер с поддержкой PHP и MySQL. Тем не менее, мы не можем тестировать каждую возможную среду на наличие возможных проблем.

Примечание. Если вы используете устаревшее окружение, где доступны только старые версии PHP или MySQL, WordPress также работает и с PHP 5.2.4+ и MySQL 5.0+, однако поддержка этих версий официально прекращена, и они могут подвергнуть ваш сайт проблемам безопасности.

Спросите об этом

Вот письмо, которое вы можете отправить своему хостинг-провайдеру; скопируйте и вставьте!

Мы заинтересованы в установке программного обеспечения с открытым исходным кодом WordPress <https://wordpress.org/> и нам интересно, поддерживается ли у вас следующее:

  • PHP 7.2 или новее
  • MySQL 5.6 или новее ИЛИ MariaDB 10.0 или новее
  • Nginx или Apache с модулем mod_rewrite
  • HTTPS

Cпасибо!

Необязательно, но рекомендуется для улучшения безопасности

Хостинг более безопасен, когда приложения PHP, такие как WordPress, запускаются с использованием вашей собственной учетной записи, а не общей (например www-data). Спросите у поддержки потенциального хостинга, какие шаги они предпринимают для обеспечения безопасности вашей учетной записи.